New to site and need help!
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

New to site and need help!
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #11  
Old 05-05-2014, 01:40 PM
IGbullshark IGbullshark is offline
Jr. Member
 

Join Date: Apr 2014
Posts: 4
New to site and need help!
Default

Ok so again, thanks for the help guys! I just watered the orchid for the first time since cutting the roots. upon examining the roots, it looks like the tips from where i cut them have rotted slightly. is this normal and will they get healthy again?
Reply With Quote
  #12  
Old 05-05-2014, 03:04 PM
La Casa de las Orquideas La Casa de las Orquideas is offline
Member
 

Join Date: Apr 2014
Posts: 51
New to site and need help!
Default

We also hate this advertising scheme!! Remember that we must try to emulate their natural conditions as much as possible, freezing water is not what they get from the rain!!
Try to think abut it like this, would you like to hold an ice cube in your hand for 3 minutes? They don't either!! They like water with a nice temperature, even a bit warm (when its cold).

About the new media... did you soak it before repotting? It's important to soak the media thoroughly so it is already saturated when you use it and the water actually goes to the roots and is not absorbed only by the media.

Don't worry to much!! We all have killed one or two (or many more) orchids in the process of getting the hang of it !!
Reply With Quote
  #13  
Old 05-11-2014, 10:53 AM
IGbullshark IGbullshark is offline
Jr. Member
 

Join Date: Apr 2014
Posts: 4
New to site and need help!
Default

Hey guys, just wanted to give a little update. I ended up not cutting off the flower spikes, just trimming the roots. After trimming the roots two of the flowers wilted within a day or two but since then none of the other flowers have died and none of the leaves have yellowed! So i think its been about a week and a half since any flowers have shown signs of dying. I know its too early to say for sure that the plant is healthy but the last orchid i had was pretty much completely gone within two weeks of showing signs of disease, so ill take it as a good sign!
Reply With Quote
Post Thanks / Like - 1 Likes
Likes RosieC liked this post
Reply

Bookmarks

Tags
dying, leaves, root, started, week, site


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:52 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2024 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.