Miltonia with wilting flowers, squishy pseudo bulb, and black marks near base
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

Miltonia with wilting flowers, squishy pseudo bulb, and black marks near base
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
Go Back   Orchid Board - Most Complete Orchid Forum on the web ! > >
Reply
 
Thread Tools Rate Thread Display Modes
  #11  
Old 05-15-2021, 03:23 AM
estación seca's Avatar
estación seca estación seca is offline
Senior Member
Miltonia with wilting flowers, squishy pseudo bulb, and black marks near base
 

Join Date: Jun 2015
Zone: 9b
Location: Phoenix AZ - Lower Sonoran Desert
Posts: 12,893
Miltonia with wilting flowers, squishy pseudo bulb, and black marks near base Male
Default

This is how they die when conditions aren't proper. I don't think the primary problem is rot. If roots are dead it is likely due to being too dry, not getting enough air or getting too hot at some point.

I don't know what happened, but Miltoniopsis are hard to revive when they start going downhill. Uprooting the plant and cutting it up is unlikely to help. I personally wouldn't let them get partly dry before watering, but I'm not a good Miltoniopsis grower.
__________________
May the bridges I've burned light my way.

Weather forecast for my neighborhood
Reply With Quote
Post Thanks / Like - 1 Likes
Likes Nicolasdperez liked this post
  #12  
Old 05-15-2021, 04:15 AM
Nicolasdperez Nicolasdperez is offline
Jr. Member
 

Join Date: Apr 2021
Posts: 13
Miltonia with wilting flowers, squishy pseudo bulb, and black marks near base
Default

Yeah, I think these have definitely seen there fair share of negligence and I agree that they are very hard to revive. I suspected the watering issue too, and increased watering on the second one displayed. After I increased the watering, all the leaves began to suddenly yellow and fall off. I guess this one must just be at end of its life time, however I think the first one should make it. Thank you for all of your help.
Reply With Quote
Reply

Bookmarks

Tags
flowers, hydrogen, peroxide, pot, repotted


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:10 AM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.