inflorescence dieback on Ascocentrum ampullaceum
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

inflorescence dieback on Ascocentrum ampullaceum
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #1  
Old 06-02-2020, 03:57 PM
Maxx Maxx is offline
Jr. Member
 

Join Date: May 2020
Location: Budapest, Hungary
Posts: 7
inflorescence dieback on Ascocentrum ampullaceum Male
Default inflorescence dieback on Ascocentrum ampullaceum

About one month ago I acquired several Ascocentrum (Vanda) species, from which now my Ampullaceum is about to bloom, however the inflorescence shows some dieback for some reason (this was also the case previously with my Garayi).

Any ideas what causes it, and how can I avoid it to affect also the other 4-5 inflorescences currently evolving?

Is it the daily misting (or the regular soaking in 20-20-20 fertilizer at 1/3 strength)? Otherwise the plant seems happy, the roots are starting to branch like hell, and also a new basal offshoot is showing.

My growing conditions: western facing window, temp 75 F, humidity 60%, watering is daily with 5 min soaking in 20-20-20 fertilizer at 1/3 strength / or misting.

Picures with a bonus garayi pic
Reply With Quote
Reply

Bookmarks

Tags
1/3, 20-20-20, ampullaceum, ascocentrum, dieback


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ascocentrum ampullaceum pheli Vanda Alliance - others 0 05-05-2018 10:01 AM
Ascocentrum ampullaceum Orchid killer Vanda Alliance - others 5 06-27-2015 03:18 AM
Wierd Blooming Time??? Ascocentrum Ampullaceum Cattleya17 Vanda Alliance - others 6 01-23-2010 05:19 PM
yellow spot on ascocentrum ampullaceum/ and black tip roots mollyminiveg Beginner Discussion 6 08-27-2009 01:13 PM
Ascocentrum Ampullaceum I need Tips! Cattleya17 Vanda Alliance - others 5 10-31-2008 03:54 PM

All times are GMT -4. The time now is 01:46 AM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.