Help! My 3 day old terrarium already has mold :(
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

Help! My 3 day old terrarium already has mold :(
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #11  
Old 08-05-2018, 06:11 PM
dethswatch dethswatch is offline
Jr. Member
 

Join Date: Jan 2016
Posts: 11
Help! My 3 day old terrarium already has mold :(
Default

I'm late to this thread but I'm growing in a exoterra 18x18x24 with high humidity and what I've learned the hard way is that mold forms when there's not enough airflow (and H is high, etc).

Find a computer fan (120mm is ideal)- I've used DELTA fan to really good effect. This sort of controller (12V Motor Speed Controller, DROK DC Motor Driver Board for Brush Motor 7V-60V 20A 420W PWM Control 12V 24V 36V 48V Regulator Cooling Fans Dimmer Governor Pulse Width Modulator with Adjust Knob: Power Converters: Amazon.com: Industrial & Scientific) will let you adjust the speed easily.

Also, standing water puts the H at nearly 100 the entire time it's around, so that make things worse, though with a fan, I haven't noticed any trouble after a couple days but have never let go farther than that.
Reply With Quote
Reply

Bookmarks

Tags
foam, mold, panel, terrarium, top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Initial plan for new terrarium DesignerofBeauty Terrarium Gardening 13 04-21-2018 08:54 PM
A New Way to Grow Terrarium Plants hydrophyte Terrarium Gardening 13 12-15-2017 05:54 PM
Mold, mold mold! It keeps reappearing! I'm not panicking… yet! donguri Pests & Diseases 21 12-14-2014 06:53 PM
Need help with mold killing my orchid roots! greenleaf Pests & Diseases 9 03-02-2010 02:24 PM
mold problem--sphag & bag Annika Pests & Diseases 13 06-15-2008 07:35 PM

All times are GMT -4. The time now is 03:22 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.