Orchid Board - Most Complete Orchid Forum on the web !

Orchid Board - Most Complete Orchid Forum on the web ! (http://www.orchidboard.com/community/)
-   Cattleya Alliance (http://www.orchidboard.com/community/cattleya-alliance/)
-   -   nageliella purpurea (http://www.orchidboard.com/community/cattleya-alliance/102122-nageliella-purpurea.html)

Dollythehun 12-30-2019 07:39 PM

nageliella purpurea
 
1 Attachment(s)
Is anyone in my climate blooming this successfully? I repotted mine today taking it out of it's tiny mesh pot and moving it to fir bark and clay. It's grown well, sent up lots of flower spike s but, never bloomed. It's under catalaya light, Watered 3-4x a week,more in warm weather (more when I think of it).

rbarata 12-30-2019 07:50 PM

Carol, can't help you on that but OW says: " The flower spikes should not be removed when flowers have faded as they will continue to grow and produce new clusters of blossoms at the tip for several years, provided the tips are undamaged."

Dollythehun 12-30-2019 08:25 PM

According to what I read, I'm doing everything right. But, I've had it two years with nary a bloom. I haven't cut a thing. Some spikes are green, some are brown. It's making new green root tips. I chose not to mount it because I forget to water my mounts.

rbarata 12-30-2019 08:40 PM

Maybe low humidity?
OW => HUMIDITY: 8085% in summer and early autumn, dropping to 7075% in winter and spring. Values may be somewhat greater in the forest habitat in winter, however.

It seems that the dry season means less watering but HR remains more or less the same.

Dollythehun 12-30-2019 09:05 PM

Usual hovering around 60-70%.

Leafmite 12-30-2019 09:28 PM

I know someone in our Orchid Society who grew this in a vase and had good luck with blooms. No idea if that helps. I do not grow it.

Dollythehun 12-30-2019 09:33 PM

I had considered that. The drawback is then fitting it under the lights.

Leafmite 12-30-2019 09:44 PM

That is true. Maybe a wide bowl with lava rock and water at the bottom to add humidity?

My problem child is Angraecum leonis. I always get buds and then they blast every year. I am trying more humidity this year...so frustrating but I love that darn orchid.

SouthPark 12-31-2019 05:33 AM

Quote:

Originally Posted by Dollythehun (Post 907861)
Is anyone in my climate blooming this successfully? I repotted mine today taking it out of it's tiny mesh pot and moving it to fir bark and clay. It's grown well, sent up lots of flower spike s but, never bloomed. It's under catalaya light, Watered 3-4x a week,more in warm weather (more when I think of it).

Maybe more light is needed. Not sure though.

Take a look at this link Click Here ...... and see the colour of the leaves. Yellowy-green. Looks like a fair amount of light.

This isn't to say that your plant isn't getting enough light though. Just an observation only.

Dollythehun 12-31-2019 07:59 AM

Wow! That is yellow! As you can see from my picture, mine is mottled purple on olive green. I've also done a lot of reading, should it even spike without enough light? I think I'm going to try the vase suggestion. Thanks Leafmite.


All times are GMT -4. The time now is 04:12 PM.

3.8.9
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.


Clubs vBulletin Plugins by Drive Thru Online, Inc.