Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.


Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #11  
Old 08-31-2018, 10:19 PM
Tdesimone911 Tdesimone911 is offline
Jr. Member
 

Join Date: Aug 2018
Posts: 9
Default Letting orchid air dry

So I got rid of most of the moss and I will let the plant air dry for a few days. I noticed some new leaves and they look sad and yellow and I really hope it wonít die! The roots were so bad that some of them just kinda fell off, it was interesting for the first time doing this by the way.
Reply With Quote
  #12  
Old 09-02-2018, 07:41 PM
Gil's Avatar
Gil Gil is offline
Jr. Member
 

Join Date: Jul 2007
Zone: 6b
Location: Mountains of NC
Posts: 29
Male
Default

The mold and poor roots tell me you have a watering issue. When I had my phals in moss and growing indoors, I let the moss dry out a bit before watering. I didn't have a watering schedule, I just checked the moss. You can use a wood toothpick embedded in the medium to check the moisture of the medium. It's just not the surface of the moss to check because the moss will hold a lot of moisture below the surface by the roots for some time.
Reply With Quote
  #13  
Old 09-03-2018, 03:27 PM
Tdesimone911 Tdesimone911 is offline
Jr. Member
 

Join Date: Aug 2018
Posts: 9
Default

I let the orchid dry out for a few days then repotted it. Well see how she does.
Reply With Quote
  #14  
Old 09-08-2018, 11:53 AM
Tdesimone911 Tdesimone911 is offline
Jr. Member
 

Join Date: Aug 2018
Posts: 9
Smile Havenít noticed any fuzzy stuff since repotting it I noticed something else

Is this a flower forming?
Attached Thumbnails
-7be9ef34-5bf5-4d19-ad08-4c0a48b18528-jpg  
Reply With Quote
Reply

Bookmarks

Tags
imperial, iím, mix, ready, roots


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! With root problems, repot, newbie and Phals Just add ice Cutiedeer Beginner Discussion 8 06-12-2016 09:04 PM
When to repot various orchids? ChatteringCat Beginner Discussion 10 03-14-2016 07:17 PM
Why aren't the blooms on my phals very big? RandomGemini Beginner Discussion 19 06-07-2014 01:07 PM
Help! First timer with wilting blooms chilecorona Beginner Discussion 4 12-31-2011 09:14 AM
Are Phals really Monopodial RosieC Advanced Discussion 17 07-25-2009 11:24 AM

All times are GMT -4. The time now is 05:31 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.