Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.


Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
Register Members O.C.D. Search Today's Posts Mark Forums Read
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #1  
Unread 03-06-2013, 02:29 PM
Brenda Aarts's Avatar
Senior Member
 

Join Date: Mar 2008
Zone: 6a
Location: London, Ontario
Posts: 877
Female
Default White mold - looking stuff

Can someone help me identify this whitish cottony stuff i came accross while repotting one of my LCs. It has no real form so I don't think it's meally....but it is scatttered throughout the media. I have stripped all old bark away from roots and am soaking in a strong hydrogen peroxide & water solution (hopefully not too strong). Leaves of the plant look clean of anything. Thanks for looking.
Attached Thumbnails
White mold - looking stuff-photo-16-300x400-.jpg  
__________________
1MOREORCHID
Reply With Quote
  #2  
Unread 03-06-2013, 02:32 PM
King_of_orchid_growing:)'s Avatar
Senior Member
 

Join Date: Apr 2008
Zone: 9a
Location: Los Angeles, CA
Posts: 7,981
Default

It's nearly impossible to specifically ID fungus without a microscope.

It is fungus though.

I recommend changing the media out. It looks like it's time.
__________________
Philip
Reply With Quote
  #3  
Unread 03-06-2013, 02:36 PM
Brenda Aarts's Avatar
Senior Member
 

Join Date: Mar 2008
Zone: 6a
Location: London, Ontario
Posts: 877
Female
Default

Quote:
Originally Posted by King_of_orchid_growing:) View Post

It is fungus though.

I recommend changing the media out. It looks like it's time.
K thanks Phillip. So the peroxide should help with the fungus right? And yes...the plant is about a year over due as far as the repotting...guess that's what I get!
__________________
1MOREORCHID
Reply With Quote
  #4  
Unread 03-06-2013, 03:47 PM
King_of_orchid_growing:)'s Avatar
Senior Member
 

Join Date: Apr 2008
Zone: 9a
Location: Los Angeles, CA
Posts: 7,981
Default

The peroxide should help to some degree. I now prefer to use potassium permanganate. Super easy to use, and a little goes a very long way. Kills a wider variety of disease organisms.
__________________
Philip
Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please HELP!!! White Mold in Newly Repotted Plants Miadunn Beginner Discussion 4 03-29-2012 04:48 PM
Help! White mold in my pot... should I repot? TinTinGirl Beginner Discussion 4 11-03-2010 04:08 AM
Phal white mold or fungus roots lassiemelove Pests & Diseases 11 08-09-2010 01:20 PM
Wrinkly leaves and white mold on roots... AThoele Beginner Discussion 11 07-01-2009 08:48 AM
White mold in s/h Buds! Semi-Hydroponic Culture 11 11-21-2007 10:15 AM

All times are GMT -4. The time now is 12:04 PM.

© 2007 OrchidBoard.com

Clubs, ShowCase vBulletin Plugins by Drive Thru Online, Inc.

SEO by vBSEO 3.6.0