White Mold on Dendrobium Media
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

White Mold on Dendrobium Media
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #1  
Old 10-14-2019, 01:52 PM
Clawhammer Clawhammer is offline
Jr. Member
 

Join Date: Aug 2019
Posts: 9
White Mold on Dendrobium Media
Default White Mold on Dendrobium Media

I saw that my new Denrobium Classic Gem (in bloom) was losing a leaf and initially I thought this was normal. However when a couple more began to yellow I inspected the pot and found the media (med/lg size bark) covered in mold. The mold smelled like mushrooms and seemed to be focused on the bark as opposed to the roots. Most of the roots in the middle were rotted suggesting that the media had been waterlogged for a while.

I am currently in the process of repotting, the first time I have done so with a dendro, which I heard could be hard on the plant. I guess my blooms are probably toast.

Any protocol that I should follow for the mold before repotting? Any tips to help prevent reoccurance and help save the plant?

Thanks in advance
Reply With Quote
  #2  
Old 10-14-2019, 01:59 PM
Roberta's Avatar
Roberta Roberta is offline
Super Moderator
White Mold on Dendrobium Media
 

Join Date: Jun 2008
Zone: 10a
Location: Coastal southern California, USA
Posts: 3,118
White Mold on Dendrobium Media Female
Default

I think just rinse the roots well. Once they're in fresh medium that has a chance to dry out between waterings, and with good air spaces, the mold won't regrow. It was a symptom of the problem, not the cause.
__________________
"Extraordinary claims require extraordinary evidence" Carl Sagan

Roberta's Orchids

What's blooming for Southern California Species hobbyists
Reply With Quote
  #3  
Old 10-14-2019, 02:00 PM
Clawhammer Clawhammer is offline
Jr. Member
 

Join Date: Aug 2019
Posts: 9
White Mold on Dendrobium Media
Default

Thanks Roberta, I was hoping that would be the case. I'm on it!
Reply With Quote
Reply

Bookmarks

Tags
bark, media, mold, plant, repotting


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Orchids with a strong scent razka3 Beginner Discussion 270 04-08-2019 11:38 AM
Dendrobium types? ilikeorchids Beginner Discussion 19 07-20-2014 08:36 PM
S/H white mold growing on roots bnegrete Semi-Hydroponic Culture 22 03-03-2014 11:44 PM
White Mold in Media...HELP!!!! DontPhalMeNow Beginner Discussion 7 04-24-2013 05:38 AM
Dendrobium media recommendations calvin_orchidL Propagation 2 03-11-2010 09:54 PM

All times are GMT -4. The time now is 07:51 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.