Miltoniopsis not opening flower buds
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

Miltoniopsis not opening flower buds
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #11  
Old 12-01-2022, 01:38 AM
dbarron dbarron is offline
Senior Member
 

Join Date: Feb 2015
Zone: 7a
Location: Arkansas
Posts: 538
Miltoniopsis not opening flower buds Male
Default

What was your media of choice?
I repotted mine day before yesterday since i was in the repotting mood. I actually planned to just upgrade the sphagnum, but I apparently bought Spanish moss vs Sphagnum, which I discovered in mid repot. So...it's now in medium orciata bark because that was finest I had. We are gonna be watering I think about every 3 days (guessing)...unless it's quite cold at the time.
Edit:I reviewed my earlier post and see that I'm predicting same watering schedule..but I think that's because bigger pot, more media, and cooler season. When summer rolls around it may be daily watering or every other day, I'm thinking. I water based on pot weight and/or foliage telling me via color or (horror) pleating.

Last edited by dbarron; 12-01-2022 at 03:08 AM..
Reply With Quote
Reply

Bookmarks

Tags
ago, buds, miltoniopsis, orchid, orchids


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fertilizer and growth of flower buds vs psuedobulbs Jeff214 Beginner Discussion 7 05-06-2015 08:38 PM
Cymbidium flower buds yellowing. bil Beginner Discussion 5 09-15-2014 03:40 PM
Premier flower opening of P. equestris The Mutant Species 11 04-30-2012 05:24 PM
Dark spots on leaves, flower spike and buds AlaskanTransplant Beginner Discussion 7 12-27-2010 10:44 PM
Cymbidium flower buds blasting ... why? Tropic Cymbidium Alliance 2 10-16-2009 10:38 PM

All times are GMT -4. The time now is 03:04 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2023 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2023 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.