Help needed. Keikis without roots!
Login
User Name
Password   


Registration is FREE. Click to become a member of OrchidBoard community
(You're NOT logged in)

menu menu

Sponsor
Donate Now
and become
Forum Supporter.

Help needed. Keikis without roots!
Many perks!
<...more...>


Sponsor
 

Google


Fauna Top Sites
LOG IN/REGISTER TO CLOSE THIS ADVERTISEMENT
  #1  
Old 11-14-2019, 10:07 PM
frank5577 frank5577 is offline
Jr. Member
 

Join Date: Nov 2019
Posts: 3
Help needed. Keikis without roots!
Exclamation Help needed. Keikis without roots!

Hello!

I have a lot of keikis in one orchid. I didnt write down when they started but for sure it has been more than one year. They are all without roots and I am starting to think maybe there is some problem. The leaves from the keikis however are growing.

There are 7 keikis, but some spots appear to have more than one keiki together so I think they are 9. In the photos you can see some moss, I put it three weeks ago to see if it starts making the roots but nothing so far.

Thanks for the help!

Photos htxxp://imgur .com/a/BDSRhbG
Reply With Quote
  #2  
Old 11-14-2019, 10:29 PM
SouthPark's Avatar
SouthPark SouthPark is offline
Senior Member
 

Join Date: Dec 2018
Member of:AOS
Location: Australia
Posts: 704
Help needed. Keikis without roots! Male
Default

Please test your image web link - just to make sure it works.

As long as those juveniles have leaves and are alive and healthy - then everything should be fine. They will produce roots eventually if the plant keeps growing healthily.

I think in general, it's better to just let the plant eventually generate roots - just naturally.

Last edited by SouthPark; 11-14-2019 at 10:36 PM..
Reply With Quote
  #3  
Old 11-14-2019, 10:32 PM
frank5577 frank5577 is offline
Jr. Member
 

Join Date: Nov 2019
Posts: 3
Help needed. Keikis without roots!
Default

It works!

I just had to remove the http for hxxp and put a space before the .com so I could put the link. As new user to avoid spam does not allow to post urls. Just edit the link with http and removing the space and should work. Thanks!
Reply With Quote
  #4  
Old 11-14-2019, 10:43 PM
SouthPark's Avatar
SouthPark SouthPark is offline
Senior Member
 

Join Date: Dec 2018
Member of:AOS
Location: Australia
Posts: 704
Help needed. Keikis without roots! Male
Default

Thanks for letting me know about the link at :

Keikis - Album on Imgur

I can now see the photos. The leaves look somewhat quite dark - perhaps it's ok. Or perhaps not enough lighting level on the plant.

One leaf looks a slightly shrivelled. Maybe not enough water. It might be better to not put the wet moss on those regions (where the keiki's are) - in case it leads to rot or something like that.

Maybe you can bump up the lighting a bit. And water a tiny bit more. But not over-do it of course.

Maintain good air-circulation (air-flow) to the plant's leaves and media and roots. Avoid still air growing (if it was growing in relatively still air).
Reply With Quote
  #5  
Old 11-14-2019, 10:52 PM
frank5577 frank5577 is offline
Jr. Member
 

Join Date: Nov 2019
Posts: 3
Help needed. Keikis without roots!
Default

Thanks southpark!

I am afraid the mother is really weak. It was the first orchid I got and I was not putting much water so it became in weak state, then keikis appeared. This was more than one year ago. Since then I read a lot and I am sure the water is ok but mother continues weak. I was thinking maybe because the mother is weak the keikis wont grow... Also I read somewhere that 7 keikis is too much for the mother.

I will remove the moss and move it a bit more near the window and see what happens. Thanks for your comment.
Reply With Quote
  #6  
Old 11-14-2019, 11:40 PM
SouthPark's Avatar
SouthPark SouthPark is offline
Senior Member
 

Join Date: Dec 2018
Member of:AOS
Location: Australia
Posts: 704
Help needed. Keikis without roots! Male
Default

Quote:
Originally Posted by frank5577 View Post
I will remove the moss and move it a bit more near the window and see what happens. Thanks for your comment.
You're most welcome. When you move it closer to the window, to allow a bit more light onto the plant, it will likely become healthier. Make sure to provide good air-circulation. Still air isn't great for orchids.

Since you've had this plant for a year, then it appears to be doing quite ok actually. If you see the newest leaves getting shivelled, and if the roots look just fine (not rotting or brown etc), then that can mean the plant is not getting enough water into it.

If possible - give this plant a weak concentration of fertiliser - maybe once a month --- just to get what they call some needed 'vitamins' into it. It definitely doesn't need much (ie. fertililser is not bulk food ..... but consider it as some ingredients for maintaining good health).

Also - just water the media only if possible. Keep the leaves dry as possible. The water will come up through the roots and into the leaves to keep the leaves hydrated.

Last edited by SouthPark; 11-14-2019 at 11:43 PM..
Reply With Quote
  #7  
Old 11-15-2019, 09:49 AM
Ray's Avatar
Ray Ray is offline
Senior Member
 

Join Date: May 2005
Location: Oak Island NC
Posts: 10,649
Help needed. Keikis without roots! Male
Default

Personally, I'd cut off the spikes and focus my attention on getting the original plant to recover.
__________________
Ray Barkalow, Orchid Iconoclast
Want Better Plants? READ THIS
shop.firstrays.com

Free Shipping in the US! (see terms & conditions for details)
Reply With Quote
Post Thanks / Like - 1 Likes
Likes Mountaineer370 liked this post
Reply

Bookmarks

Tags
keikis, lot, photos, roots, spots


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice needed with dendrobium roots & repotting HUMMINGBIRDem Beginner Discussion 46 03-28-2018 06:12 AM
Did I repot the Cattleya right? CourtneyT Cattleya Alliance 13 02-12-2018 11:31 AM
Dendrobium Nobile keikis not putting out roots? mexicowpants Beginner Discussion 12 04-19-2016 07:34 PM
Advice needed: Den. wassellii piece has roots cbuchman Dendrobium Alliance 3 05-11-2015 01:13 PM
arial roots vs buried roots james mickelso Beginner Discussion 0 06-30-2012 08:32 PM

All times are GMT -4. The time now is 05:12 PM.

© 2007 OrchidBoard.com
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Clubs vBulletin Plugins by Drive Thru Online, Inc.